#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)^" & @CRLF & _
"(?P<street>[^-\n]+)" & @CRLF & _
"(?:-\h*)?" & @CRLF & _
"(?P<town>(?:(?!\b[A-Z]{2}\b).)*)" & @CRLF & _
"(?P<state>\b[A-Z]{2}\b)?\h*" & @CRLF & _
"(?P<zip>[-\d]*)" & @CRLF & _
"$"
Local $sString = "123 Ave Ave - Hoquiam WA 98103" & @CRLF & _
"123 Ave Ave - Hoquiam, WA 98103" & @CRLF & _
"123 Ave Ave - Hoquiam, WA 98103-1345" & @CRLF & _
"123 Ave Ave - Hoquiam" & @CRLF & _
"123 Ave Ave - Ocean Shores WA" & @CRLF & _
"123 Ave Ave - Ocean Shores, WA" & @CRLF & _
"123 Ave Ave - D'ile, WA" & @CRLF & _
"123 Ave Ave" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")