$re = '/[a-zA-Z]+_const/mi';
$str = 'This is the string and I want to match varstring_const with regex.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);