$re = '/^\+65(\s?)[689]\d{3}\1\d{4}$/m';
$str = '+6581234567
+65 8123 4567
+65 81234567
+658123 4567
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);