using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(hardrock)[^-]";
string input = @"matt,hardrock,victor,ben,hardrock,rocker,ranzian,hardrock,hardrock,victor,alpha,matt,hardrock-victor,ben,hardrock,rocker,ranzian,hardrock,matt,hardrock,victor,ben,hardrock,rocker,ranzian,hardrock,hardrock,victor,alpha,matt,hardrock-victor,ben,hardrock,rocker,ranzian,hardrock";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}