#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((\d+).*)(\.html)"
Local $sString = "2020-spisok-shindlera.html" & @CRLF & _
"/god/1993.html" & @CRLF & _
"dramy.html" & @CRLF & _
"zarubezhnye-serialy.html" & @CRLF & _
"strana/США.html" & @CRLF & _
"rezhissjor/Дэвид+Наттер.html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")