#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?<year>\d{4})[-\/](?<month>0[1-9]|1[0-2])[-\/](?<day>0[1-9]|[1-2][0-9]|3[0-1])(?:[T\s](?:(?<hour>0[0-9]|1[0-9]|2[0-4]):(?<minute>\d{2}):(?<second>\d{2})(?:\.(?<nano>\d+))?))?(?:(?<offset>[Zz]|(?:[+-])(?:[01]\d|2[0-3])(?::?[0-5]\d)?)?)$"
Local $sString = "2020-12-01T12:13:51.123+02:00" & @CRLF & _
"2020-12-01T12:13:51.123+0200" & @CRLF & _
"2020-12-01T12:13:51.123Z" & @CRLF & _
"2020-12-01T12:13:51.123" & @CRLF & _
"2020-12-01T12:13:51.123341512+02:00" & @CRLF & _
"2020-12-01T12:13:51.123341512+0200" & @CRLF & _
"2020-12-01T12:13:51.123341512Z" & @CRLF & _
"2020-12-01T12:13:51.123341512" & @CRLF & _
"2020-12-01T12:13:51+02:00" & @CRLF & _
"2020-12-01T12:13:51+0200" & @CRLF & _
"2020-12-01T12:13:51Z" & @CRLF & _
"2020-12-01T12:13:51" & @CRLF & _
"2020-12-01 12:13:51.123 +02:00" & @CRLF & _
"2020-12-01 12:13:51.123 +0200" & @CRLF & _
"2020-12-01 12:13:51.123Z" & @CRLF & _
"2020-12-01 12:13:51.123" & @CRLF & _
"2020-12-01 12:13:51.123341512 +02:00" & @CRLF & _
"2020-12-01 12:13:51.123341512 +0200" & @CRLF & _
"2020-12-01 12:13:51.123341512Z" & @CRLF & _
"2020-12-01 12:13:51.123341512" & @CRLF & _
"2020-12-01 12:13:51+02:00" & @CRLF & _
"2020-12-01 12:13:51+0200" & @CRLF & _
"2020-12-01 12:13:51Z" & @CRLF & _
"2020-12-01 12:13:51" & @CRLF & _
"2020-12-01+02:00" & @CRLF & _
"2020-12-01+0200" & @CRLF & _
"2020-12-01Z" & @CRLF & _
"2020-12-01" & @CRLF & _
"2020/12/01T12:13:51.123+02:00" & @CRLF & _
"2020/12/01T12:13:51.123+0200" & @CRLF & _
"2020/12/01T12:13:51.123Z" & @CRLF & _
"2020/12/01T12:13:51.123" & @CRLF & _
"2020/12/01T12:13:51.123341512+02:00" & @CRLF & _
"2020/12/01T12:13:51.123341512+0200" & @CRLF & _
"2020/12/01T12:13:51.123341512Z" & @CRLF & _
"2020/12/01T12:13:51.123341512" & @CRLF & _
"2020/12/01T12:13:51+02:00" & @CRLF & _
"2020/12/01T12:13:51+0200" & @CRLF & _
"2020/12/01T12:13:51Z" & @CRLF & _
"2020/12/01T12:13:51" & @CRLF & _
"2020/12/01+02:00" & @CRLF & _
"2020/12/01+0200" & @CRLF & _
"2020/12/01Z" & @CRLF & _
"2020/12/01" & @CRLF & _
"2039/15/23" & @CRLF & _
"2923/09/12" & @CRLF & _
"2023/23/51" & @CRLF & _
"2020-12-01T00:13:51" & @CRLF & _
"2020-12-01T01:13:51" & @CRLF & _
"2020-12-01T10:13:51" & @CRLF & _
"2020-12-01T19:13:51" & @CRLF & _
"2020-12-01T20:13:51" & @CRLF & _
"2020-12-01T24:13:51"
Local $sSubst = "$1-$2-$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)