$re = '/\b(?<!\.)((\d{3}[ .-]?){2}(\d{4}))(?!\.)\b/m';
$str = '1231231234
123.123.1234
123-123-1234
123 123 1234
123.1231231234
1231231234.123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);