#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[(?P<timestamp>[\w-]+\s[\w:]+[+\.]\d+)\] \[(?P<level>\S+)\]\:(?P<bho>\s+)\t\{(?P<id>\d+)\} \[(?P<telefono>\S+)\] \[(?P<ip>\S+)\] (?P<node>\w*)\s*\[(?P<path>\S+)?\s\]\[(?P<bho2>\s\d+\s)\]\[\s(?P<id2>\d+\s)\]"
Local $sString = "[2020-05-22 12:49:09.1640] [info]: {2012} [393471039213] [10.8.19.191] MASTER [netmon.condiviso_368-pwc ][ 160239552803493 ][ 1292 ]" & @CRLF & _
"" & @CRLF & _
"[2020-02-13 01:01:03.9170] [info]: {2} [393454639076] [10.8.4.218] MASTER [netmon.condiviso_368-pwc ][ 160130554375066 ][ 1855 ]" & @CRLF & _
"" & @CRLF & _
"[2020-02-13 02:10:05.5750] [info]: {499} [393481505158] [10.8.17.5] [netmon.traffico.393481505158.10.8.17.5_371-pwc ][ 4880942571 ][ 16274 ]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")