$re = '/([(][0-9]{2}[)])?[0-9]{4,5}-?[0-9]{4}/m';
$str = '(11)2536-2652 2536-2652 (11)92536-2652 92536-2652 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);