$re = '/\D|^(.)\1*$/m';
$str = '086945159
589ac2546
111111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);