package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9]+)[_-].*`)
var str = `4123499-TESCO45-123
every99999994_54
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}