$re = '/\d{6,}/';
$str = '4123499-TESCO45-123
every99999994_54
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);