$re = '/^((?!Not)Funny)*$/m';
$str = 'Not Funny';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);