using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/\S*""";
string input = @"{""created_at"": ""Fri Aug 12 10:04:00 +0000 2016"", ""id"": 764039724818272256, ""text"": ""@theblaze https://t.co/TY9DlZ584c @realDonaldTrump "", ""in_reply_to_screen_name"": ""theblaze"", ""user"": {""id"": 366636488, ""id_str"": ""366636488"", ""name"": ""GIL DUPUY"", ""screen_name"": ""DUPUY77"", ""location"": ""Miami"", ""url"": ""http://ggm-dupuy.com"", ""description"": ""Fashion photographer, love action and adventure, care for the less fortunate, don't tolerate any kind of racism regardless of race or religion"", ""verified"": false, ""followers_count"": 186, ""friends_count"": 446, ""utc_offset"": null, ""time_zone"": null, ""lang"": ""en"", ""default_profile_image"": false, ""following"": null, ""notifications"": null}, ""geo"": null, ""coordinates"": null, ""place"": {""name"": ""Frontenac"", ""full_name"": ""Frontenac, MO"", ""country_code"": ""US"", ""country"": ""United States"", ""attributes"": {}}, ""retweet_count"": 0, ""favorite_count"": 0, ""extended_entities"": {""media"": [{""id"": 764039718237409281, ""id_str"": ""764039718237409281"", ""indices"": [27, 50], ""media_url"": ""http://pbs.twimg.com/media/CppqE1_UkAE2qFj.jpg"", ""media_url_https"": ""https://pbs.twimg.com/media/CppqE1_UkAE2qFj.jpg"", ""url"": ""https://t.co/TY9DlZ584c"", ""display_url"": ""pic.twitter.com/TY9DlZ584c"", ""expanded_url"": ""http://twitter.com/DUPUY77/status/764039724818272256/photo/1"", ""type"": ""photo"", ""sizes"": {""medium"": {""w"": 640, ""h"": 1136, ""resize"": ""fit""}, ""large"": {""w"": 640, ""h"": 1136, ""resize"": ""fit""}, ""thumb"": {""w"": 150, ""h"": 150, ""resize"": ""crop""}, ""small"": {""w"": 383, ""h"": 680, ""resize"": ""fit""}}}]}, ""favorited"": false, ""retweeted"": false, ""possibly_sensitive"": false, ""lang"": ""und""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}