package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)test(,|$)`)
var str = `test,test,test
test$test$test
test|test|test
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}