package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<ph>.*?) __ (?P<A>.*?) __ (?P<B>.*?) __ \( (?P=ph) \-> (?P=A) = (?P=B) \) \)$`)
var str = `y = N __ ( A \` y ) __ ( A \` N ) __ ( y = N -> ( A \` y ) = ( A \` N ) ) )
BLABLA __ ( A \` y ) __ ( A \` N ) __ ( y = N -> ( A \` y ) = ( A \` N ) ) )
then the code above provides the exact same value`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}