re = /(\/.*\.[\w:]+)/m
str = 'file path /log/file.txt some lines /log/var/file2.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end