using System; using System.Text.RegularExpressions; public class Example { public static void Main() { string pattern = @"(?:\+|\-)(?=([^""]*""[^""]*"")*[^""]*$)"; string input = @"""