$re = '/((?:"((?:[^"]|"")*)")|(?:\'((?:[^\']|\'\')*)\')|([^,;]*))(?:[,;]|$)/m';
$str = 'v-dakash@catalysis.com,"HEY"? Tester, 12345789,"Catalysis", LLC.,\' Enterprise 6 TEST\', etc,etc ,etc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);