re = /{\K[^}]+(?=})/m
str = 'dashboard/admin/{content}/category/{category}/posts'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end