const regex = /(\b.+?)=(.+?)(,|\\n\\n)/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b.+?)=(.+?)(,|\\\\n\\\\n)', 'igm')
const str = `aaaa=1111, bbb=222asdasd, ccc=33@as4@3, ddd=4\$*(*#@\$@\$\\n\\n`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}