$re = '/\bcoversyl\b\s(\bplus\b|\+)/m';
$str = 'coversyl +
coversyl +
coversyl plus
coversyl plus
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);