re = /\[\[((?:(?!\]\]).)*)\]\]/m
str = 'participant Tracking [[http://www.yahoo.com]] again [[more]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end