package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`lang="(.+?)"`)
var str = `<p lang="en" langDirection="rtl">CONTENT HERE</p>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}