# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!000|666)[0-9]{3}([ -]?)(?!00)[0-9]{2}\1(?!0000)[0-9]{4}$"
test_str = ("123456789\n"
"123 45 6789\n"
"123-45-6789\n"
"899-45-6789\n"
"001-23-4567\n\n\n"
"12345 6789\n"
"123 456789\n"
"123x45x6789\n"
"ABCDEEEEE\n"
"1234567890123\n"
"000-45-6789\n"
"123-00-6789\n"
"123-45-0000\n"
"666-45-6789")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.