# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
<zwr:risicoNiveau>(.*?)</zwr:risicoNiveau>\s*
<zwr:numeriekeWaarde>(.*?)</zwr:numeriekeWaarde>\s*
<zwr:eenheid>(.*?)</zwr:eenheid>\s*
<zwr:hoedanigheid>(.*?)</zwr:hoedanigheid>\s*
<zwr:kwaliteitsOordeel>(.*?)</zwr:kwaliteitsOordeel>\s*
<zwr:parameterGrootheid>\s*
<zwr:grootheid>(.*?)</zwr:grootheid>\s*
<zwr:object>(.*?)</zwr:object>\s*
</zwr:parameterGrootheid>
"""
test_str = ("<zwr:resultaat>\n"
" <zwr:objectBeginTijd>2012-09-18</zwr:objectBeginTijd>\n"
" <zwr:resultaatHistorie>\n"
" <zwr:datumInvoeren>2012-10-31</zwr:datumInvoeren>\n"
" <zwr:invoerder>\n"
" <zwr:voornaam>Joep</zwr:voornaam>\n"
" <zwr:achternaam>Koning, de</zwr:achternaam>\n"
" <zwr:email>jdekoning@hhdelfland.nl</zwr:email>\n"
" <zwr:telefoon>015-2608166</zwr:telefoon>\n"
" <zwr:organisatie>\n"
" <zwr:bedrijfsnaam>Hoogheemraadschap van Delfland</zwr:bedrijfsnaam>\n"
" <zwr:adres>\n"
" <zwr:huisnummer>32</zwr:huisnummer>\n"
" <zwr:postcode>2611AL</zwr:postcode>\n"
" <zwr:straat>Phoenixstraat</zwr:straat>\n"
" <zwr:woonplaats>DELFT</zwr:woonplaats>\n"
" </zwr:adres>\n"
" <zwr:email>info@hhdelfland.nl</zwr:email>\n"
" <zwr:telefoon>(015) 260 81 08</zwr:telefoon>\n"
" <zwr:website>http://www.hhdelfland.nl/</zwr:website>\n"
" </zwr:organisatie>\n"
" </zwr:invoerder>\n"
" </zwr:resultaatHistorie>\n"
" <zwr:risicoNiveau>false</zwr:risicoNiveau>\n"
" <zwr:numeriekeWaarde>0.02</zwr:numeriekeWaarde>\n"
" <zwr:eenheid>kubieke millimeter per liter</zwr:eenheid>\n"
" <zwr:hoedanigheid>niet van toepassing</zwr:hoedanigheid>\n"
" <zwr:kwaliteitsOordeel>Normale waarde</zwr:kwaliteitsOordeel>\n"
" <zwr:parameterGrootheid>\n"
" <zwr:grootheid>Biovolume per volume eenheid</zwr:grootheid>\n"
" <zwr:object>Microcystis</zwr:object>\n"
" </zwr:parameterGrootheid>\n"
" <zwr:analyseProces>\n"
" <zwr:analyserendeInstantie>AQUON</zwr:analyserendeInstantie>\n"
" </zwr:analyseProces>\n"
"</zwr:resultaat>\n\n"
"<zwr:resultaat>\n"
" <zwr:objectBeginTijd>2012-09-18</zwr:objectBeginTijd>\n"
" <zwr:resultaatHistorie>\n"
" <zwr:datumInvoeren>2012-10-31</zwr:datumInvoeren>\n"
" <zwr:invoerder>\n"
" <zwr:voornaam>Joep</zwr:voornaam>\n"
" <zwr:achternaam>Koning, de</zwr:achternaam>\n"
" <zwr:email>jdekoning@hhdelfland.nl</zwr:email>\n"
" <zwr:telefoon>015-2608166</zwr:telefoon>\n"
" <zwr:organisatie>\n"
" <zwr:bedrijfsnaam>Hoogheemraadschap van Delfland</zwr:bedrijfsnaam>\n"
" <zwr:adres>\n"
" <zwr:huisnummer>32</zwr:huisnummer>\n"
" <zwr:postcode>2611AL</zwr:postcode>\n"
" <zwr:straat>Phoenixstraat</zwr:straat>\n"
" <zwr:woonplaats>DELFT</zwr:woonplaats>\n"
" </zwr:adres>\n"
" <zwr:email>info@hhdelfland.nl</zwr:email>\n"
" <zwr:telefoon>(015) 260 81 08</zwr:telefoon>\n"
" <zwr:website>http://www.hhdelfland.nl/</zwr:website>\n"
" </zwr:organisatie>\n"
" </zwr:invoerder>\n"
" </zwr:resultaatHistorie>\n"
" <zwr:risicoNiveau>false</zwr:risicoNiveau>\n"
" <zwr:numeriekeWaarde>0.02</zwr:numeriekeWaarde>\n"
" <zwr:eenheid>kubieke millimeter per liter</zwr:eenheid>\n"
" <zwr:hoedanigheid>niet van toepassing</zwr:hoedanigheid>\n"
" <zwr:kwaliteitsOordeel>Normale waarde</zwr:kwaliteitsOordeel>\n"
" <zwr:parameterGrootheid>\n"
" <zwr:grootheid>Biovolume per volume eenheid</zwr:grootheid>\n"
" <zwr:object>Microcystis</zwr:object>\n"
" </zwr:parameterGrootheid>\n"
" <zwr:analyseProces>\n"
" <zwr:analyserendeInstantie>AQUON</zwr:analyserendeInstantie>\n"
" </zwr:analyseProces>\n"
"</zwr:resultaat>")
matches = re.finditer(regex, test_str, re.DOTALL | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.