#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!(?:\\{2})*\\)(?:(?<begin_capture>[\(])(?<begin_capture_modifier>(?=[<][a-z_A-Z]+[>])|(?!\?(?:<?[=!]|:)))|(?<begin_non_capture>\((?=\?(?:<?[=!]|:))))|(?:(?<end>\)))"
Local $sString = "// Basic - Repeat Delimiters" & @CRLF & _
"/^((?:([gimsuy])(?!.*\\2))*)/gm" & @CRLF & _
"" & @CRLF & _
"// Basic - Nested - Captured | Non-captured" & @CRLF & _
"^(?:(// +)(?:(@noframes)([ \t]*$)|(@(?:include|match|grant|require))([\t ]+)(?:(https?.+?)|(.+))(\**)([ \t]*)|(^//[ \t]+)(@(?:author|name(?:space)?|version|description))([ \t]+)(.+?)([ \t]*)|(^//[ \t]+)(@resource)([ \t]+)(\S+)([ \t]+)(\S+)([ \t]*))(\n(?://[ \t]*\n)*))" & @CRLF & _
"" & @CRLF & _
"// Basic - Captured | Non-captured | Lookbehind Positive" & @CRLF & _
"(?<=^[ \t]*)(//)([ ])(?<capture_name>)(Case:)([ \t]+)(.*\S)([ \t]*)?$" & @CRLF & _
"" & @CRLF & _
"// Complex" & @CRLF & _
"(?<=^[ \t]*)(//)([ ])(Case:)([ \t]+)(.*\S)([ \t]*)?$"
Local $sSubst = "\n - $begin_capture"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)