$re = '/\bона\b/u';
$str = 'йсчфкесч ешкчфкешчг она
она йсчфкесч ешкчфкешчг она.
йсчфкесч ешкчфкешчг она .
йсчфкесч ешкчфкешчг анона.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);