$re = '/\b\sона\b|\bона\s\b/u';
$str = 'она и я
я и она
и она я';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);