package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(segev)`)
var str = `https://www.load61_242.0.Context/segev/2/a7/8a/`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}