package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(([-+\/*\bmod\b])*`)
var str = `dfdf4534534*^(+`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}