re = /(?:data-href=")(.*?)(?:">)/m
str = 'data-href="www.buxmob.net/index.php?id=577">
data-href="www.webopedia.com/TERM/K/keyword.html">
data-href="moz.com/beginners-guide-to-seo/keyword-research">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end