package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\[\]\*\?\:\/\\\s]+`)
var str = `hola / como [ estas ] a ************ ddfhgd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}