re = /(?:\?|&)(foo[^=]*=[^&]+)(?:&|$)/
str = 'http://example.com?foo=bar&baz=boo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end