#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([[:xdigit:]]{1,4}(?::[[:xdigit:]]{1,4}){7}|::|:(?::[[:xdigit:]]{1,4}){1,6}|[[:xdigit:]]{1,4}:(?::[[:xdigit:]]{1,4}){1,5}|(?:[[:xdigit:]]{1,4}:){2}(?::[[:xdigit:]]{1,4}){1,4}|(?:[[:xdigit:]]{1,4}:){3}(?::[[:xdigit:]]{1,4}){1,3}|(?:[[:xdigit:]]{1,4}:){4}(?::[[:xdigit:]]{1,4}){1,2}|(?:[[:xdigit:]]{1,4}:){5}:[[:xdigit:]]{1,4}|(?:[[:xdigit:]]{1,4}:){1,6}:)$"
Local $sString = "::" & @CRLF & _
                "::123" & @CRLF & _
                "::123:456" & @CRLF & _
                "::123:456:789" & @CRLF & _
                "::123:456:789:abc:def:6666" & @CRLF & _
                "::123:456:789:abc:def:6666:7" & @CRLF & _
                "" & @CRLF & _
                "123::456" & @CRLF & _
                "123::456:789" & @CRLF & _
                "123::456:789:abc" & @CRLF & _
                "123::456:789:abc:def" & @CRLF & _
                "123::456:789:abc:def:6" & @CRLF & _
                "123::456:789:abc:def:6:7" & @CRLF & _
                "" & @CRLF & _
                "123:456::789" & @CRLF & _
                "123:456::789:abc" & @CRLF & _
                "123:456::789:abc:def" & @CRLF & _
                "123:456::789:abc:def:6666" & @CRLF & _
                "123:456::789:abc:def:6666:7" & @CRLF & _
                "" & @CRLF & _
                "123:456:789::abc" & @CRLF & _
                "123:456:789::abc:def" & @CRLF & _
                "123:456:789::abc:def:6666" & @CRLF & _
                "123:456:789::abc:def:6666:7" & @CRLF & _
                "" & @CRLF & _
                "123:456:789:abc::def" & @CRLF & _
                "123:456:789:abc::def:6666" & @CRLF & _
                "123:456:789:abc::def:66666:7" & @CRLF & _
                "" & @CRLF & _
                "123:456:789:abc:def::6666" & @CRLF & _
                "123:456:789:abc:def::6666:7" & @CRLF & _
                "" & @CRLF & _
                "123:456:789:abc:def:6666::" & @CRLF & _
                "123:456:789:abc:def::" & @CRLF & _
                "123:456:789:abc::" & @CRLF & _
                "123:456:789::" & @CRLF & _
                "123:456::" & @CRLF & _
                "123::" & @CRLF & _
                "" & @CRLF & _
                "123::456:789:abc:def:6666" & @CRLF & _
                "123:456:789:abc:def:6666:7" & @CRLF & _
                "123::456::abc" & @CRLF & _
                ""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")