re = /(?P<field>^[\w-]+): *(?P<value>[\s\S]+?)(?=^[\w-]+: *|\Z)/m
str = 'Message-ID: <1608636066635.7f830.79689714@crcvmail15.nm>
Received: from 125.209.x.x (net58.219.x-x.host.lt-nn.net [91.219.x.x])
by crcvmail15.google.com with ESMTP id +844Q-zuS122aEqk5CZDZg
for <test@google.com>;
Received: from 125.209.x.x (net58.219.x-18.host.lt-nn.net [91.219.x.x])
by crcvmail15.google.com with ESMTP id +844Q-zuS122aEqk5CZDZg
for <test@google.com>;
Tue, 22 Dec 2020 11:20:58 -0000
From: "test"<from@google.com>
To: test@google.com
Subject:example email
Content-Type: text/html; charset="utf-8"
Content-Transfer-Encoding: quoted-printable'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end