re = /((?<=[A-Z]{4})|^).*?(?=[A-Z]{4}|$)/
str = 'The following trials have no study data-available, in the RBM mart. It appears as is this because they were . In y HIWEThe trials currently missing data are: JADA, JPBD, JVCS, JADQ, JVDI, JVDO, JVTZ '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end