$re = '/^[1-9][0-9]{5}$/m';
$str = '123465
025463
-213325
612123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);