package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^((?:apple|mango|banana| )+) is (\d+)kg\s?$`)
var str = ` is 45kg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}