import re
regex = re.compile(r"""
(?<callsign>\w+?)>APRS,.+?,
(?<receiver>\w+):\/
(?<time>\d{6})h
(?<latitude>\d{4}\.\d{2}[NS]).
(?<longitude>\d{5}\.\d{2}[EW]).
(?:(?<heading>\d{3})\/(?<ground_speed>\d{3}))?.*?
\/A=(?<altitude>\d{6})\s
(?:!W((?<latitude_enhancement>\d)(?<longitude_enhancement>\d))!)?
(?:v(?<version>\d+\.\d+\.\d+)(?:\.(?<platform>.+?))?\s)?
CPU:(?<cpu_load>[\d.]+)\s
RAM:(?<ram_free>[\d.]+)\/(?<ram_total>[\d.]+)MB\s
NTP:(?<ntp_offset>[\d.]+)ms\/(?<ntp_correction>[+-][\d.]+)ppm\s?
(?:(?<cpu_temperature>[+-][\d.]+)C\s*)?
(?:RF:
(?:
(?<manual_correction>[+-][\d]+)
(?<automatic_correction>[+-][\d.]+)ppm\/
)?
(?<signal>[+-][\d.]+)dB
)?
""", flags=re.VERBOSE)
test_str = ("LKHS>APRS,TCPIP*,qAC,GLIDERN2:/211635h4902.45NI01429.51E&000/000/A=001689 v0.2.4.ARM CPU:0.2 RAM:777.7/972.2MB NTP:3.1ms/-3.8ppm +33.6C RF:+62-0.8ppm/+33.66dB\n\n"
"Moosburg>APRS,TCPIP*,qAC,GLIDERN1:/232205h4827.52NI01155.89E&000/000/A=001397 v0.2.4.ARM CPU:0.8 RAM:788.7/1017.6MB NTP:16000.0ms/-73.4ppm RF:+8.00dB")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")