const regex = /(?!.*(Printer|Cartridge|Toner).*(Kit|Bundle|Set))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!.*(Printer|Cartridge|Toner).*(Kit|Bundle|Set))', '')
const str = `Some string`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}