import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE) # Definitions\n"
+ " (?<needle>\\\\dfrac(?=[^\\}]*\\})) # What to search for\n"
+ " (?<skip>^[^\\{]*\\{|\\}[^\\{]*\\{) # What we should skip\n"
+ ")\n"
+ "(?&skip)(*SKIP)(*FAIL) # Skip it\n"
+ "|\n"
+ "(?&needle) # Match it";
final String string = "Démontrer par récurrence que pour tout entier naturel n,\n"
+ "\\dfrac\n"
+ "\\(\\displaystyle{1^2+2^2+\\ldots+n^2=\\sum_{k=0\\dfrac dsdq ds}rr^{n}k^2=\\dfrac{n(n+1)(2n+1)}{6}}\\)\n"
+ "Démontrer par récurrence que pour tout entier naturel n,\n\n"
+ "\\(\\displaystyle{1^2+2^2+\\ldots+n^2=\\sum_{k=0\\dfrac{test} fdfd}^{n}k^2=\\dfrac{n(n+1)(2n+1)}{6}}\\)\n\n"
+ "\\dfrac";
final String subst = "\\\\frac";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}