using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(?:(?!\/>).)+?>.*?<\/[^>]*>";
string input = @"<style src=""./x.css"" /><style src=""./z.css"">cccccc</style>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}