import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\@if(not)?:([a-zA-Z0-9]+)(?:=(.*?))?\\].*?\\[\\@endif:\\2\\]";
final String string = "<!-- <h1>[!WLANSettings]</h1> -->\n"
+ "[@if:examplevar=notgiven]this text won't show[@endif:examplevar]\n"
+ "[@if:wlanena]\n"
+ "[@if:wlanauto]\n"
+ "<table id=\"wlanavail\" class=\"colorrows inputtable\">\n"
+ " <tr id=\"firstrow\">\n"
+ " <th width=\"30px\"></th>\n"
+ " <th width=\"240px\">[!Name] (SSID)</th>\n"
+ " <th width=\"110px\">[!Encryption]</th>\n"
+ " <th width=\"150px\">[!SignalStrength]</th>\n"
+ " <th width=\"200px\">[!MAC]</th>\n"
+ " </tr>\n\n"
+ " <tr id=\"loadingrow\">\n"
+ " <td colspan=5 class=\"centertext\"><img src=\"resources/loading.gif\"\n"
+ " id=\"loadingWlanScan\"></td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td></td>\n"
+ " <td colspan=4><input type=\"button\" id=\"rescan\"\n"
+ " value=\"[!Refresh]\" style=\"width: 200px\"></td>\n"
+ " </tr>\n"
+ "</table>\n"
+ "<p></p>\n"
+ "[@endif:wlanauto]\n"
+ "<table id=\"wlansettings\" class=\"inputTable\">\n"
+ " <tr id=\"wlannamerow\" [@if:wlanauto]style=\"display: none;\"[@endif:wlanauto]>\n"
+ " <td>[!WLANName]</td>\n"
+ " <td><input type=\"text\" name=\"wlanname\" id=\"wlanname\"\n"
+ " [@if:wlanauto]value=\"[@wlanname]\"[@endif:wlanauto] style=\"width: 309px;\"></td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td>[!Password]:</td>\n"
+ " <td><input type=\"text\" name=\"wlanpass\" id=\"wlanpass\"\n"
+ " style=\"width: 309px;\"></td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td colspan=\"2\" >\n"
+ " <input type=\"button\" \n"
+ " [@if:wlanauto]id=\"manualcfg\" name=\"manualcfg\" value=\"[!ManualConfig]\"[@endif:wlanauto]\n"
+ " [@ifnot:wlanauto]id=\"autocfg\" name=\"autocfg\" value=\"[!AutomaticConfig]\"[@endif:wlanauto]\n"
+ " onclick=\"handleMultiform(event, this);\" style=\"width: 180px;\">\n"
+ " </td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td>\n"
+ " <input type=\"hidden\" name=\"encinput\" id=\"encinput\" value=\"\"></td>\n"
+ " <td id=\"wlaninfo\"></td>\n"
+ " </tr>\n"
+ "</table>\n"
+ "[@ipsettings]\n\n"
+ "[@endif:wlanena]\n"
+ "[@ifnot:wlanena]\n"
+ "[!NoWLANDevicePluggedIn]\n"
+ "<p>\n"
+ " <input type=\"button\" name=\"back\" onclick=\"handleMultiform(event, this);\" value=\"[!Back]\" />\n"
+ "</p>\n"
+ "[@endif:wlanena]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}