import re
regex = re.compile(r"(pa)(?!([^<]+)?>)", flags=re.MULTILINE)
test_str = "'The pattern to <span class=\"something\">be replaced is pa but only outside the html tag</span>'"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)