#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)'\$([\d]*)[\.]?(\d+)'"
Local $sString = "#Test-2019-8" & @CRLF & _
"" & @CRLF & _
"#1.'do+g'" & @CRLF & _
"dog, doooog, abcdogef," & @CRLF & _
"asdooooijk dooog asdoogghj" & @CRLF & _
"'dog', 'doooog', 'abcdogef'" & @CRLF & _
"" & @CRLF & _
"#2. 'ab*d'" & @CRLF & _
"ad, abd, abbbd" & @CRLF & _
"'ad', 'abd', 'abbbbd'" & @CRLF & _
"'sad', 'cabd', 'abbbds'" & @CRLF & _
"" & @CRLF & _
"#3. '[xy]{2}AB'" & @CRLF & _
"'xxAB', 'xyAB','yyAB' '2xxAB'" & @CRLF & _
"" & @CRLF & _
"#4. '[a-z].?'" & @CRLF & _
"'aA', 'b9', 'z' 'bX'" & @CRLF & _
"'aB z8 b6'" & @CRLF & _
"" & @CRLF & _
"#5. '5[abc]?ef'" & @CRLF & _
"'5aef', 'a5bef', '5ef' '5ef'" & @CRLF & _
"" & @CRLF & _
"#6. Taiwan ID : '([A-Z])([12])(\d{8})','[A-Z][12]\d{8}'" & @CRLF & _
"'A102926987', 'B212345678'" & @CRLF & _
"" & @CRLF & _
"#7. mobile tel_num:'(09)(\d\d)[-\s](\d{3})[-\s](\d{3})' " & @CRLF & _
"'0988 123 456', '0978-456-789'" & @CRLF & _
"# : '09\d\d[-\s]\d\d\d'" & @CRLF & _
" '0924-357'" & @CRLF & _
"" & @CRLF & _
"#8. Home tel_num:" & @CRLF & _
"# '([\(]?\d\d[\)-]?)([\d]{4})([-\s]{1}[\d]{4})' " & @CRLF & _
"'(02)2257 3150', '02-2250-3457','(12)2245 3214'" & @CRLF & _
"# '[\(]?(0[23])[\)-]?(\d{4})'" & @CRLF & _
"'(02)2345', '03-1348'" & @CRLF & _
"" & @CRLF & _
"#9. Date Time:yyyy/mm/dd " & @CRLF & _
"#'(20[12]\d)[-\/]([1]?[\d])[-\/]([1-3][\d])'" & @CRLF & _
"'2019/1/25', '2018-12-31'" & @CRLF & _
"#'(20[12]\d)[-\/]([01]\d)[-\/](\d{2})'" & @CRLF & _
"'2019/01/15' ,'2020-11-28'" & @CRLF & _
"" & @CRLF & _
"#10. floating number: '\$([\d]*)[\.]?(\d+)'" & @CRLF & _
"'$123.34', '$2345' '$0.234' ,'1.87'" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")