$re = '/((?:NA|PO|EO|PRO)\s+){14}/';
$str = 'NA NA NA NA NA NA NA NA NA NA NA NA NA NA ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);