#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<li><a.+?>(.+)?<\/.+>"
Local $sString = "!-- The following setting enables collapsible lists -->" & @CRLF & _
" <p>" & @CRLF & _
" <a href="#human">Human</a></p>" & @CRLF & _
"" & @CRLF & _
" <p class="collapse-section">" & @CRLF & _
" <a class="collapsed collapse-toggle" data-toggle="collapse" " & @CRLF & _
" href=#mammals>Mammals</a>" & @CRLF & _
" <div class="collapse" id="mammals">" & @CRLF & _
" <ul>" & @CRLF & _
" <li><a href="#alpaca">Alpaca</a>" & @CRLF & _
" <li><a href="#armadillo">Armadillo</a>" & @CRLF & _
" <li><a href="#sequence_only">Armadillo</a> (sequence only)" & @CRLF & _
" <li><a href="#baboon">Baboon</a>" & @CRLF & _
" <li><a href="#bison">Bison</a>" & @CRLF & _
" <li><a href="#bonobo">Bonobo</a>" & @CRLF & _
" <li><a href="#brown_kiwi">Brown kiwi</a>" & @CRLF & _
" <li><a href="#bushbaby">Bushbaby</a>" & @CRLF & _
" <li><a href="#sequence_only">Bushbaby</a> (sequence only)" & @CRLF & _
" <li><a href="#cat">Cat</a>" & @CRLF & _
" <li><a href="#chimp">Chimpanzee</a>" & @CRLF & _
" <li><a href="#chinese_hamster">Chinese hamster</a>" & @CRLF & _
" <li><a href="#chinese_pangolin">Chinese pangolin</a>" & @CRLF & _
" <li><a href="#cow">Cow</a>" & @CRLF & _
" <li><a href="#crab-eating_macaque">Crab-eating_macaque</a>" & @CRLF & _
" <div class="gbFooterCopyright">" & @CRLF & _
" © 2017 The Regents of the University of California. All " & @CRLF & _
" Rights Reserved." & @CRLF & _
" <br>" & @CRLF & _
" <a href="https://genome.ucsc.edu/conditions.html">Conditions of " & @CRLF & _
" Use</a>" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")