import re
regex = re.compile(r"\b(?-i)(?!vacation\b)\b(?i)(PTO|paid time off|time off|holiday|vacation)\b", flags=re.MULTILINE)
test_str = ("I want to take 5 days pto\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")