re = /^([a-zA-Z]+)!([a-zA-Z]+)@([a-zA-Z0-9.-]+)$/m
str = 'sendername!receivername@clientdomaine
totest!special@character'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end